Microsoft Office 365 services down for some users
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 10:46 CDT
Identified
Some users nationwide are unable to access Microsoft Office 365 services. Symptoms include the inability to launch Outlook or Outlook web. Other Office products may be impacted. We have seen some users impacted by this outage. Other BWI users have not been impacted. Will will update you as Microsoft updates us.
Posted Sep 12, 2024 - 07:41 CDT
This incident affected: Office 365 Services.